easyswoole一键安装脚本及宝塔安装错误问题

常见问题

在新接触easyswoole的phper中,经常遇到以下几个问题

安装步骤多 麻烦

宝塔等集成环境下容易出错

自己会安装,但是懒 有没有一键的?

开始创造

本人作为easyswoole开发组组员之一。为生态的完善和偷懒着想,在某一天讨论中就开始有了这个想法。

并且写下了这个小脚本

需要注意的是,这只是几句很简单的命令,并且在文档中都有出现。只是文档有比较多的场景描述,可能导致有些新人没有细心观看到。

在宝塔面板中,如果按照easyswoole文档第一步骤进行安装的话,是会产生错误的,在文档后续步骤会有解决方案,但是很多新人到了报错这里就不看了,或者就走了弯路。

使用这个脚本,可以直接安装成功,比较方便

最大的作用还是偷懒吧~

正文

#!/bin/bash
composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/;
composer require easyswoole/easyswoole=3.x;
php vendor/easyswoole/easyswoole/bin/easyswoole install;
php easyswoole start;

后续会将脚本放在服务器中,提供下载,真正达到一行命令安装。

注意点

该脚本会把全局的composer镜像切换为阿里云。

安装好了会默认自动启动

知识点扩展:

Linux宝塔安装EsaySwoole

安装EsaySwoole  链接:https://www.easyswoole.com/Manual/2.x/Cn/_book/Introduction/install.html

宝塔面板安装的swoole扩展不一定支持最新版本的 EsaySwoole 

且宝塔面板的swoole扩展升级不容易

所以只能卸载自己重新编译安装扩展Swoole

Swoole扩展地址 https://pecl.php.net/package/swoole

找到需要的版本

下载swoole:wget https://pecl.php.net/get/swoole-4.3.1.tgz

解压:tar -zxvf  你自己下载的压缩包

进入解压后的文件:cd swoole-4.3.1

生成configure文件:phpize

编译:

./configure --with-php-config=/www/server/php/73/bin/php-config  //你自己PHP环境的文件所在目录

编译安装swoole

make && make install


make
make install

最后在配置文件php.ini末尾加上

extension = swoole.so

总结

以上所述是小编给大家介绍的easyswoole一键安装脚本及宝塔安装错误问题,希望对大家有所帮助,如果大家有任何疑问请给我留言,小编会及时回复大家的。