写一个测试gd的脚本test.php,然后在命令行执行,报错信息如下:

php test.php
libpng warning: Application was compiled with png.h from libpng-1.5.6
libpng warning: Application is running with png.c from libpng-1.2.49
libpng error: Incompatible libpng version in application and library
[read_png_file] png_create_read_struct failed

很纳闷,在编译gd、php的时候,已经指定了png的位置–with-png-dir=/usr/local/libpng,使用的是1.5.6,为什么执行的时候还会调用自带的libpng-1.2.49 ,于是把系统的 libpng-1.2.49 删除掉(因为是测试环境,就随便删了,线上服务器自重),重新编译php,我了个去,编译不过去,提示:(这里是因为gd有调用,导致php编译gd库的时候找不到)

/usr/bin/ld: cannot find -lpng12
collect2: ld returned 1 exit status
make: *** [sapi/fpm/php-fpm] Error 1

我擦,默认会调用系统的库!!!编译调用png的地方就只有2个,一个是php的编译参数–with-png-dir=/usr/local/libpng, 另一个是gd库,于是重新编译gd,在编译的时候发现这样的2行:

原来在gd这里,就已经调用了系统的libpng-1.2.49。 这里顺便说下,libpng12 、libpng15、libpng16 数字就是代表版本号1.2.X ,1.5.X ,1.6.X 具体可以看

ls /usr/include/libpng* 知道问题所在,解决问题就比较有针对性了,2个方法:

1、把系统自带的给删除了,这个觉得比较不靠谱,怕有互相依赖,有后遗症就不好了。

删除后编译的时候就变成:

checking for libpng12-config... no
checking for libpng-config... /usr/local/bin/libpng-config

2、两个版本都可以保留,编译后,修改Makefile文件。

修改262行左右 LIBPNG12_CONFIG的值,改成跟LIBPNG_CONFIG 一样即可,如:

LIBPNG12_CONFIG = /usr/bin/libpng12-config
LIBPNG_CONFIG = /usr/local/bin/libpng-config

修改成

LIBPNG12_CONFIG = /usr/local/bin/libpng-config
LIBPNG_CONFIG = /usr/local/bin/libpng-config

然后就make && make install就OK了。